Slow UK Booking Widget
Incident Report for ResDiary
Postmortem

Yesterday (2020-08-05) at around 16:45, we received reports of slow response times for booking.resdiary.com (the widget). We immediately decided to scale out this service in order to handle more traffic while we investigated. By around 17:25, the widget had recovered to a satisfactory level.

We identified that the root cause of this issue was a server silently malfunctioning following a release earlier in the day, this left the widget with half the usual capacity and caused response times to suffer.

We'd like to apologise for any disruption that may have been caused to you and your clients during this period, and thank you for your patience. We take incidents like this seriously and plan to implement changes to our service monitoring in order to prevent this from reoccurring.

Posted Aug 06, 2020 - 11:10 UTC

Resolved
The booking widget experienced an issue causing response times to increase. This issue has been resolved and we are investigating the original cause.
Posted Aug 05, 2020 - 16:00 UTC