Incident affecting UK diaries
Incident Report for ResDiary
Postmortem

From around 03:00 BST on 22/06/2020 one of the databases serving our UK diaries began using more resources than normal, which led to reduced performance for diaries. At around 09:10 our engineers began to investigate the problem, and identified a particular query as the cause. At 09:33 they took action to reduce the resource usage of the problem query, and by around 09:50 system performance began to improve again.

We are going to investigate improvements to our alerting as a result of this, as well as whether we need to increase available resources as a result of increased usage of diaries as countries are beginning to recover from COVID-19.

Posted Jun 22, 2020 - 10:23 UTC

Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 09:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 22, 2020 - 08:54 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 22, 2020 - 08:37 UTC
Investigating
We are currently investigating an issue affecting UK diaries that may cause degraded performance for users.
Posted Jun 22, 2020 - 08:24 UTC
This incident affected: ResDiary Application (UK/Europe).