Degraded performance of diary application in the UK/Europe Region
Incident Report for ResDiary
Postmortem

Incident Report

At around 18:44 on Monday the 4th of February our diary applications started to experience problems communicating with our application database because of problems within Microsoft’s Azure infrastructure. This caused diaries to run increasingly slowly and, in some cases, prevent users from logging in to the diary. The Azure problems were resolved at 19:03 and the diary performance quickly returned to normal for most users although some users may have experienced degraded performance for approximately 10 more minutes.

Future Remediation

We plan on investigating how to make our diaries more resilient when third-party infrastructure events occur in the future.

Posted Feb 05, 2020 - 14:01 UTC

Resolved
The UK / European instances of our diary applications experienced slow performance and some availability issues starting from 18:45 and ending at 19:05.
Posted Feb 04, 2020 - 19:00 UTC