Intermittent access to Settings section in the Diary
Incident Report for ResDiary
Resolved
The incident has been resolved
Posted Apr 02, 2024 - 11:18 UTC
Investigating
We are currently investigating the issue
Posted Apr 02, 2024 - 10:49 UTC
This incident affected: ResDiary Application (UK/Europe).