UK Diary Bad Gateway Error

Incident Report for ResDiary

Postmortem

We were alerted to degraded performance across our services at 04:37am on June 11th 2025. Our Engineers responded to the alert immediately, with additional engineers being called in at 05:52am.

A full investigation has been completed into the cause, and steps needed to safeguard our services moving forward:

Root Cause

An Azure CDN endpoint that our system is reliant on failed, without any warning from the 3rd party.

On 11th of June 2025 the Let’s Encrypt SSL certificate for `*.azureedge.net` expired leading all secure traffic to be blocked.

The PowerShell command “Install-PackageProvider” which was used in a start-up script for the application uses the CDN endpoint "onegetcdn.azureedge.net", which was impacted by the expired SSL certificate.

This was the root cause of the incident.

Corrective actions Taken

We are removing any instances of the Install-PackageProvider command in our scripts and migrating them to AnyPackage (Install-Module) which is more actively maintained. Measures are also being taken to improve pipeline build times.

The ultimate goal to safeguard our services is to re-platform away from VMSS, which is currently being investigated and planned.

We sincerely apologise for the disruption to service experienced, and will take every precaution and measure needed to avoid such incidents moving forward.

Thanks,

ResDiary.

Posted Jun 16, 2025 - 13:50 UTC

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 10:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2025 - 09:24 UTC

Update

We've identified a fix and are in the process of deploying it.
Posted Jun 11, 2025 - 08:54 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2025 - 07:34 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 11, 2025 - 07:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2025 - 05:53 UTC

Investigating

We are currently investigating this issue.
Posted Jun 11, 2025 - 03:52 UTC
This incident affected: ResDiary Application (UK/Europe) and API, Widget, Reserve with Google.